This page is a mirror of Tepples' nesdev forum mirror (URL TBD).
Last updated on Oct-18-2019 Download

Concerning Sprite 0 hits

Concerning Sprite 0 hits
by on (#45325)
Hi, I seem to be lucky and find all kinds of bugs in the NES PPU by myself.
:?

My question is: does Sprite 0 hit detection work when the X coordinate of Sprite 0 is $ff ? Because it doesn't in my game code. $fe works fine, $ff = zip, nada, although the sprite is clearly visible in the last pixel column.

Thanks again for your help.

by on (#45327)
It doesn't work, it's known before but probably not documented anywhere noticeable.

by on (#45335)
Memblers wrote:
It doesn't work, it's known before but probably not documented anywhere noticeable.


Ok, thanks. I'm using several sources for my research and so far, I did not encounter this bug being documented. Is there any definitive PPU documentation available which is up to date?

by on (#45358)
6502freak wrote:
Memblers wrote:
It doesn't work, it's known before but probably not documented anywhere noticeable.


Ok, thanks. I'm using several sources for my research and so far, I did not encounter this bug being documented. Is there any definitive PPU documentation available which is up to date?


Brad Taylor's 2C02 tech reference is the most complete doc that I'm aware of.

I've said something like this before in another thread, but it seems like a lot of the undocumented things are little non-intuitive quirks like this one. I think we kind of need an "NES errata sheet". If nothing else, I guess we can get those edited into the new wiki.

BTW, this reminds me, this little sprite #0 quirk was the fatal flaw in my old RTC (Retrocoders) demo. Such a ridiculously easy fix, but I had no idea and no devkit back then. It's amusing how my demo detects certain emulators and warns about inaccuracies, yet crashes on the real system. heh