This page is a mirror of Tepples' nesdev forum mirror (URL TBD).
Last updated on Oct-18-2019 Download

DASM Frontend...

DASM Frontend...
by on (#20045)
I've created a small utility (.NET 1.1 required) for the DASM, 6502 compiler. I was so tired of playing around with DOS-programs so I created this frontend for it.
It's in a very early beta-stage so use with care at the moment.

Anyway, it allows you to edit your asm-files and compile & run them in your favourite emulator at the click of a button, sort of. It comes with a built-in NES header editor that it merges with the final binary file..
The settings for your NES-header are saved in your sourcefile so they will stay the same the next time you open your source..
You need to manually adjust the paths to your emulator and to your DASM.EXE in the preferences. I've used it with nintendulator but it should be usable with others if they accept ROM-names as a command-parameter.

Anyway it should be pretty easy to use. But remember, it's was all thrown together in an hour or two so beware, many things are not yet implemented.

The file can be downloaded at: http://www.anes.se/NESAssembler.zip

by on (#21415)
As a beginner, I would like to use and test this except it tells me DASM.exe is not found, even though I directed it to DASM in the preferences.

Any suggestions?.

by on (#21516)
How did you enter the pathname? Make sure you use a "\" at the end.. Sorry, was to lazy to fix that earlier.. :)

by on (#21563)
Thanks, I just tried setting the path like this:

C:\Documents and Settings\Colin\Desktop\DASM22010b\DASM\bin\DOS\dasm.exe\


It still tells me DASM.exe is not found? Any ideas?

by on (#21565)
Maca wrote:
C:\Documents and Settings\Colin\Desktop\DASM22010b\DASM\bin\DOS\dasm.exe\

Uh... I didn't try this, but "dasm.exe" sure seems wrong. Did you try "C:\Documents and Settings\Colin\Desktop\DASM22010b\DASM\bin\DOS"?

Maybe the program knows that it has to find a file named "dasm.exe", so you just need to specify the path to it, not including the file itself.

by on (#21569)
Yes, that worked thanks.

by on (#21608)
I'll do an update soon to fix this stupid issue.. :)